How to restart a conversation on Skype?

Mārcis Pinnis 7 years ago updated by anonymous 5 years ago 12

Hi, I published a bot on Skype, but it is unclear how to restart the conversation once it is finished. Does anyone know how to do it?

What I tried so far: Adding a reset node at the end and linking it to home. But after re-publishing the reset node does not trigger!

Any ideas?


Hi Marcis,

To restart a conversation, you can use a GoTo Node at the end of the Story. Or, user can type /restart for the bot to restart from the beginning.

Hi, thanks, but it does not work on Skype!

THe command "/restart" just triggers a Skype message:


Available commands:
/me [text]
/add [skypename+]
/alertson [text]
For more help please see http://www.skype.com/go/help.chathelp


And the GoTo node did not make a difference after re-publishing (Update) also.

Adding GoTo Node and linking it up at the start node of your bot will restart the bot. Could you please point me to your bot link at onsequel.com and I'll be able to look into it?

There IS a GoTo Node linking up at the first node under Home (I had reset nodes linking the Home node, but it did not work ... and logically, it does not matter, as the Home node is empty).

The link (not sure whether this is correct) is: https://www.onsequel.com/channels/11971/episodes/20645 (I copied the link from the editor).

When you look at it, please look also at why the following keyword list sequence fails (and selects the No Match Node):

1) jā, esmu

The issue is that the keyword "jā" is defined in the node that should have triggered: "ja, jaa, gribu, velos, veelos, jā, labi, vēlos". (it works if I use "ja, esmu").

On Messenger/Skype the following keyword list sequence (without any letters with diacritics marks ... however ... "jā" (yes) is not the same as "ja"(if) ... so support of UTF-8 is important!) just stops:

1) ja

2) salami

3) ja

4) ja

5) kolu

6) ja

The keywords for the node are: "pareizi, ja, jaa, taisniba, taisniiba, jā, taisnība" (so ... "ja" is one of the keywords).

On your simulator in the editor the sequence works just fine! It breaks in the deployments.


I checked the bot at onsequel.com and looks like the GoTo Nodes are added correctly. Regarding the NLP keywords, words with diacritics will not match with any user input without diacritics. However, using words without diacritics will work correctly.

Hi, I see that you have misunderstood the issue with keywords. There are multiple actually:

1) I belive keywords with diacritics marks often do not trigger at all (seems like some component - probably the one that you use for tokenisation or the "NLP" stuff - does not support UTF-8).

2) Sometimes for some reason keywords without diacritics marks are not triggered when using the bot through Messenger or Skype.

I did not by no means try to capture a word without diacritics marks as a keyword with diacritics marks (Although I know that some search engines also do this as a Romanisation feature - I do not think that it is smart to have such a feature for keyword processing ... especially because words with diacritics marks can mean totally different things ... as I explained above).

... These two actually correspond to the first and second example. If you read my comment (above) carefully (without subjective pre-conditioned bias), you will understand that I explained these two issues (and the examples clearly show the issues).

This is how the "stopping" looks line in Messenger. The bot simply does not reply. It is stuck! Note that all entered keywords are listed in the node: "pareizi, ja, jaa, taisniba, taisniiba, jā, taisnība". If I enter something that is not in the keyword list, the bot moves to the No Match Node:

So the issue is with your platform not being able to reply when triggering keywords in the particular node.

Note that in the last sequence there are no diacritics marks used!


Sorry about the confusion. I got it now. We'll have this debugged further to check if this form of NLP matching can be supported.

Ok, great! I will be waiting for an update then ;o)

Any update on the non-triggering of keywords issue? Just checked the old bot and I see that the issue has not been solved.


This has not been resolved yet. Will keep you posted on this.